先日、海外からのbotによる大量スパムコメント被害の連絡あり対応しました。WordPress標準のコメント欄のままだったので、まず不審なIPアドレスを特定、アクセス拒否の処置をして、さらにWordPressのコメントプラグイン「wpDiscuz」と、Googleのスパム対策機能「reCAPTCHA(リキャプチャ)」の導入をしました。
その際、wpDiscuzに記載の説明をしっかり理解せずに、Googleの最新画面(Enterprise版やv3)の指示通りに進めたら、「エラー:キータイプが無効です」と表示されて動かないという状態に。その後上手くできたので記事にまとめておきます。
今回は、現時点で無料で、迷うことなくスムーズに「私はロボットではありません」のチェックボックスをwpDiscuzに導入する手順を分かりやすくお話したいと思います。
reCAPTCHA 導入前に知っておくべき超重要ポイント
- wpDiscuzの無料版は「v2(チェックボックス型)」のみ対応しています。画面に出ない自動判定型(v3)を使うには有料アドオンが必要になるため、今回は完全無料で使える「v2」で設定します。
- Googleの最新の管理画面(Google Cloud / Enterprise版)のキーは互換性がなくエラーになります。必ず「Classic版(従来版)」のページからキーを発行する必要があります。
ステップ1:Google reCAPTCHA(従来版)でキーを取得する
まずはGoogleのアカウントにログインした状態で、キーを発行します。
- Google reCAPTCHA(従来版)の登録ページにアクセスします。
「従来版(Classic)」Google reCAPTCHA 従来版作成ページ のリンクからアクセスもできますが、WordPressの左メニューから 「wpDiscuz」>「Settings」 を開き、上部にある 「reCAPTCHA」 タブをクリックします。画像のように「ドメインを登録してください」のテキストリンクからキー作成ページにアクセスできます。

- 必要事項を入力する
画面が表示されたら、以下のように各項目を設定します。

- ラベル: 管理用の名前です。「ブログA」「メインブログ」など、自分で識別しやすい名前を入力します。
- reCAPTCHA タイプ: 必ず 「reCAPTCHA v2」 を選択し、その下に現れる 「『私はロボットではありません』チェックボックス」 にチェックを入れてください。
- ※「非表示 reCAPTCHA バッジ」や「reCAPTCHA v3」を選ぶとエラーになるので注意!
- ドメイン: あなたのブログのドメイン(例:
example.com)を入力して「追加」を押します。- ※
https://や末尾の/は含めず、ドメイン部分だけを入力します。サブドメイン(例:://example.com)でも登録可能です。
- ※
- AMPに関して: 「このキーがAMPに対して機能する」という項目は、基本的にチェックを外したままで大丈夫です。
- 送信してキーをコピーする
利用規約に同意し、画面最下部の 「送信」 ボタンをクリックします。
画面に 「サイトキー(Site Key)」 と 「シークレットキー(Secret Key)」 の2つの文字列が表示されるので、両方をコピーするかメモしておきます。

ステップ2:wpDiscuz(WordPress側)にキーを設定する
続いて、あなたのブログのWordPress管理画面に移ります。
- wpDiscuzの設定画面を開く
WordPressの左メニューから 「wpDiscuz」>「Settings」 を開き、上部にある 「reCAPTCHA」 タブをクリックします。 - コピーしたキーを貼り付ける
- ReCaptcha Site Key: 先ほどGoogleで取得した「サイトキー」を貼り付けます。
- ReCaptcha Secret Key: 同じく「シークレットキー」を貼り付けます。

- 適用範囲を確認して保存する
- Enable for Guests(ゲスト用に有効化): ここが ON(緑色) になっていることを確認します(通常、スパムを送ってくるのはログインしていないゲストのため)。ゲストに対して『私はロボットではありません』チェックボックスが表示されます。
- 最後にページ最下部にある 「Save Changes(変更内容を保存)」 をクリックします。
ステップ3:動作確認をする
設定が完了したら、正しく表示されているか確認しましょう。
WordPressにログインしたままだと確認できない場合があるため、ブラウザの「シークレットモード(プライベートブラウズ)」などを開き、未ログインの状態でブログ記事のコメント欄を見に行きます。
コメント送信ボタンの近くに、綺麗な 「私はロボットではありません」のチェックボックス が表示されていれば、無事に設定完了です。
「エラー:キータイプが無効です」と表示される場合
もしブログ側で上記のエラーが出ている場合、以下のいずれかが原因です。
- キー作成時に「reCAPTCHA v3」や「非表示(Invisible)」を選んでしまっている。
- Google Cloudの「Enterprise(企業向け新仕様)」でキーを作ってしまっている。
この場合は、一度wpDiscuzに入力したキーを空欄にして保存(リセット)した上で、再度ステップ1の「従来版作成ページ」から「reCAPTCHA v2(チェックボックス型)」を選んで作り直してください。
まとめ
以上がwpDiscuzにGoogle reCAPTCHAを設定する方法でした。気をつけるポイントについては設定ページに記載があるので、読みながら設定するだけでスムーズに進むと思います。
急いでいるときや意味がわかりずらいこともあるので、この記事がお役に立てると嬉しいです。最後までご覧いただきありがとうございました。
これからwpDiscuzを導入する場合、方法などはこちらの記事もご覧ください。日本語化するとさらに使いやすくなります。


